Product refreshes each time you use it, even when no changes have been made to it

Product refreshes each time you use it, even when no changes have been made to it

Symptoms

When you use a product in Order Entry or any other part of the system that uses products, the product refreshes every time, even though no changes have been made to it and you are able to use the product after it refreshes.

Cause

This can happen when the product is sent via Simple Data Transfer and the senders computer date/time is ahead of the recipient.

When Simple Data Transfer downloads and creates the files on the recipients system it retains the date/time of the sender. If the senders time is ahead of the receipient then the file on the recipient will also be ahead. When the system access the product file it will see that the XML file is older than the product file so it will attempt to re-create it as it should. However, the new XML file will still have an older date because the product file is a few hours ahead.

Resolution

To resolve this problem the recipient can open the product in Product Designer and make a minor change. This will cause the date/time on the product file to reset to the local time. Then when the XMl file is created it will be in sync with the original product file.

Another solution is to wait until the local time is just past the date/time of the product file. Then when the product is accessed the XML file will be newer than the product file which will prevent it from getting re-created each time.

Status

Solatech has confirmed this to be a problem with the software listed at the end of this article. As more information becomes available this article will be updated.

Applies To:

  • Solatech Window Covering Software 4.2

    • Related Articles

    • How to use the Product Compare feature in SalesPRO

      Summary The Product Compare feature allows you to quickly compare products, styles and options for multiple products  The comparisons are shown in columns on one screen and can be printed for review with your customer. Instructions From within a ...
    • How to use the Product Designer Inventory Assistant

      Summary This article explains how to use the Product Designer Inventory Assistant. More Information The Product Designer Inventory Assistant is a utility that can be used to perform functions that are not available in the Inventory Setup module of ...
    • How to use Item Replace in SalesPRO

      Summary Beginning with version 5.0.263 of SalesPRO, users can now change product, style and options for multiple line items on a Quote or Sale.  This article provides instructions on how to make these changes Instructions From within Order Entry, ...
    • How to use the Replace feature in Solatech Focus

      How to use the Replace feature in Solatech Focus Summary Solatech Focus users have the ability to replace products and/or options quickly on an existing quote or sale. This knowledge base article provides instructions on how to use this feature. ...
    • Changes to customer record and customer list

      Summary Solatech Focus customer records now contain a new field, Customer Name. This change was made in order to implement QuickBooks Online integration. This knowledge base article will describe the changes and how they will affect your customer ...