Product does not get added to the system when doing a Product Refresh
Symptoms
After performing a Product Refresh in Product Manager to add a new product the product is not added. When looking in the Event Log the following error is listed:
The product 'xxx' from the product file 'yyy' could not be added. More information to follow.
Incorrect syntax near ','. (-2147217900)
Cause
This is caused by missing data in the product properties portion of the product database. This can occur when a product is upgraded from previous versions.
Resolution
To fix this problem the product properties must be re-saved.
- Run Product Designer.
- Click File, Open.
- Select the product that is not getting added to Product Manager and click Open.
- From the File menu, click Product Properties.
- Without making any changes, click OK.
- Close Product Designer.
- The product should now get added to the product list in Product Manager during the next Product Refresh.
Status
Solatech has confirmed this to be a problem with the software listed at the end of this article. As more information becomes available this article will be updated.
Applies To:
- Solatech Window Covering Software 4.2
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