Problems with True OLE DBGrid 7 prevent software from running

Problems with True OLE DBGrid 7 prevent software from running

Symptoms

When starting various Solatech applications the following error message appears:

DLL module TODGUB7.DLL is missing, corrupt or incompatible with the current version of the

True OLE DBGRid 7.

DataMode will be set to dgbBound.


You may also see this message when you attemp to perform certain tasks in the software. For example, in SWCS you receive this message when viewing a list of customers or starting Order Entry.

Cause

This can be caused when certain registry entries required by the software that use this third-party module (True DB Grid 7) are deleted, for example when some applications are uninstalled.

Resolution

To resolve the problem the missing registry entries need to be added back to the Windows Registry. Perform the steps in resolution 1 first. If that does not solve the problem then perform the steps in resolution 2.

Resolution 1

  1. Close any running applications.
  2. Open an elevated command prompt window (click Start, Programs, Accessories. Right-click on Command Prompt and choose 'Run as Administrator').
  3. At the command prompt, type CD\ and press Enter.
  4. If you are running on a 32-bit operating system type CD Windows\System32 and press Enter. If you are running on a 64-bit system then type CD Windows\SysWOW64 and press Enter.
  5. Unregister some files by typing the following four commands:
  6. Type REGSVR32 /u tdbg7.ocx and press Enter. Click OK when the unregistered successful message appears.
  7. Type REGSVR32 /u todg7.ocx and press Enter. Click OK when the unregistered successful message appears.
  8. Type REGSVR32 /u todgub7.dll and press Enter. Click OK when the unregistered successful message appears.
  9. Type REGSVR32 /u xadb7.ocx and press Enter. Click OK when the unregistered successful message appears.
  10. Now register those same four files by typing the following four commands:
  11. Type REGSVR32 tdbg7.ocx and press Enter. Click OK when the registered successful message appears.
  12. Type REGSVR32 todg7.ocx and press Enter. Click OK when the registered successful message appears.
  13. Type REGSVR32 todgub7.dll and press Enter. Click OK when the registered successful message appears.
  14. Type REGSVR32 xadb7.ocx and press Enter. Click OK when the registered successful message appears.
  15. Type exit and press Enter to close the command prompt window.
  16. Run the application.

Resolution 2

  1. Close any running applications.
  2. Download and run hot fix 461444 from http://www.solatech.com/downloads/hotfixes/hf461444.exe
  3. Run the application to see if the problem has been resolved.

Status

Solatech has confirmed this to be a problem with the software listed at the end of this article. As more information becomes available this article will be updated.

References:

For more information, refer to the following knowledge base articles:

  • Hot Fix 461444

Applies To:

  • Product Designer 4.0
  • Product Designer 4.1
  • Product Designer 4.2
  • Solatech Window Covering Software 4.0
  • Solatech Window Covering Software 4.1
  • Solatech Window Covering Software 4.2

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