Error when importing into QuickBooks Desktop

Error when importing into QuickBooks Desktop

When trying to import my QuickBooks Desktop .iif file, I get the following error

You cannot associate an item with Sales Tax Payable, Undeposited Funds, accounts receivable, accounts payable, or non-posting

Cause

There can be a number of different causes for this type of error but the most common occurs when the sales tax item on the order being imported is not setup in QuickBooks Desktop (QBD) or it is setup in QBD but as a Service item instead of a Sales Tax Item.

Resolution

First identify the sales tax code that is being used on the order(s) being imported. You can do this by looking at the order in SWCS (SalesPro) Order Entry. Then open the Items List in QBD and locate the matching sales tax item.

  • If you don't see one then add a sales tax item to QBD using the same name as the sales tax code in SWCS.
  • If you have a sales tax item in QBD, check its type. If it's setup as a service type then that is most likly the cause and needs to be fixed. You won't be able to change the type of this item in QBD so first try to delete it. If it's not being used you'll be able to delete it. Once deleted you can add the sales tax item correctly and try the import again. If you can't delete it then you'll need to add a new sales tax item to QBD with a different name, rename the matching sales tax code in SWCS and re-export the affected orders.

    • Related Articles

    • Common problems when importing into QuickBooks Desktop

      Overview This article will explain solutions to common problems that you may encounter when exporting from SalesPRO and import into QuickBooks. You can't change the type of a name or add duplicate name. This can occur if you attempt to import an ...
    • Unusual data is getting added to QuickBooks Desktop

      Overview When reviewing your QuickBooks Desktop (QBD) company you may see data such as accounts, items, vendors, etc. that you don't recognize. This article will explain where some of these items may come from if you're importing SalesPRO data into ...
    • Importing customers from external sources into Focus

      Summary Solatech Focus users have the ability to import customers from external sources, such a CRM systems. In order to do this, the data exported from the outside source must be formatted in a certain way before import. This knowledge base article ...
    • What data is exported to QuickBooks Desktop

      Overview This article explains what data is exported from SalesPRO when QuickBooks Desktop (QBD) is selected as the accounting application. QuickBooks Desktop Employees Employee Name - This the full name which is made up of the First M. Last. Home ...
    • Requirements for exporting certain data to QuickBooks Desktop

      Overview This article will explain what data is required when exporting to QuickBooks. QuickBooks Desktop Sales Tax Codes Tax Agency/Vendor. This must reference the name of a vendor in QuickBooks that is setup to collect sales tax. This is not ...